Protel 99 SE
Training Manual

PCB Design
# Contents

1 PCB Design Process .................................................................................................................. 1

2 The PCB Editor Workspace ...................................................................................................... 2
   2.1 PCB Editor Panel .................................................................................................................. 2
      2.1.1 Browse Section ............................................................................................................. 2
      2.1.2 MiniViewer .................................................................................................................. 2
      2.1.3 Current Layer Section .................................................................................................. 3
   2.2 Using the Panel to Browse .................................................................................................. 3
      2.2.1 Browsing Nets .............................................................................................................. 3
      2.2.2 Browsing Components ............................................................................................... 4
      2.2.3 Browsing Libraries ..................................................................................................... 5
      2.2.4 Browsing Net Classes ............................................................................................... 6
      2.2.5 Browsing Component Classes ................................................................................... 7
      2.2.6 Browsing Design Rule Violations .............................................................................. 8
      2.2.7 Browsing Design Rules ............................................................................................ 9
      2.2.8 Exercises – Using the MiniViewer ............................................................................. 9
   2.3 Preferences Dialog Box ...................................................................................................... 10
      2.3.1 Options Tab ................................................................................................................ 10
      2.3.2 Display Tab ................................................................................................................. 13
      2.3.3 Colours Tab ................................................................................................................. 15
      2.3.4 Show/Hide Tab .......................................................................................................... 16
      2.3.5 Default Primitives Tab .............................................................................................. 18
      2.3.6 Signal Integrity Tab ................................................................................................... 18
      2.3.7 Exercises – Exploring the Preferences ..................................................................... 19
   2.4 Document Options Dialog Box .......................................................................................... 20
      2.4.1 Layers Tab ................................................................................................................ 20
      2.4.2 Options Tab ................................................................................................................ 21
   2.5 The PCB Coordinate System ............................................................................................. 21
   2.6 Grids ..................................................................................................................................... 22
      2.6.1 Snap Grid .................................................................................................................... 22
      2.6.2 Visible Grid ............................................................................................................... 22
      2.6.3 Electrical Grid ........................................................................................................... 22
      2.6.4 Component Grid ....................................................................................................... 22
   2.7 Shortcut Keys for Setup Options ....................................................................................... 23
      2.7.1 Exercises – Exploring the Document Options ......................................................... 23

3 Creating a New PCB .................................................................................................................. 24
   3.1 Printed Circuit Board Wizard ............................................................................................ 24

4 Transferring Design Information to the PCB ........................................................................... 25
   4.1 Design Synchronization ...................................................................................................... 25
   4.2 Resolving Synchronization Errors .................................................................................... 26
   4.3 Summary ............................................................................................................................ 27
   4.4 Cross Reference File ......................................................................................................... 27
   4.5 Design Transfer Using a Netlist ........................................................................................ 28
      4.5.1 Loading a Netlist ......................................................................................................... 28
      4.5.2 Resolving Netlist Loading Errors .............................................................................. 29
7.9 Re-Annotation ........................................................................................................ 54
8 Routing ....................................................................................................................... 55
8.1 Interactive Routing ................................................................................................. 55
  8.1.1 Managing Connectivity ................................................................................. 55
  8.1.2 Track Width ................................................................................................... 55
  8.1.3 Interactive Routing Mode .............................................................................. 55
  8.1.4 Look Ahead Routing ...................................................................................... 55
  8.1.5 Interactive Routing Properties ....................................................................... 55
  8.1.6 Loop Removal ................................................................................................ 55
8.2 Automatic Routing ................................................................................................. 57
  8.2.1 Automatic Routing Tips ................................................................................. 57
  8.2.2 Setting Up the Automatic Router ................................................................... 57
  8.2.3 Autorouter Options ....................................................................................... 58
9 Polygons ..................................................................................................................... 59
  9.1 Placing a Polygon ............................................................................................... 59
  9.2 Editing a Polygon ............................................................................................... 60
  9.3 Moving a Polygon .............................................................................................. 61
  9.4 Editing Polygon Vertices .................................................................................... 61
  9.5 Deleting a Polygon ............................................................................................. 61
  9.6 Exercises – Working with Polygons .................................................................... 61
10 Design Rule Checking .............................................................................................. 62
  10.1 On-Line DRC .................................................................................................. 62
  10.2 Design Rules Check Report ............................................................................. 63
  10.3 Locating Design Rule Violations ...................................................................... 63
  10.4 Exercise ............................................................................................................ 64
11 Printing ...................................................................................................................... 65
  11.1 Running Print/Preview ...................................................................................... 65
  11.2 Setting Scale and Orientation and Printer Options ......................................... 68
  11.3 Copying Print Preview to the Window Clipboard ............................................ 68
  11.4 PPC Documents ............................................................................................... 68
12 CAM Manager .......................................................................................................... 69
  12.1 Bill Of Materials ............................................................................................... 71
  12.2 DRC ............................................................................................................... 71
  12.3 Gerber ............................................................................................................. 72
  12.4 NC Drill ............................................................................................................ 72
  12.5 Pick and Place ................................................................................................. 73
  12.6 Test Point Report ............................................................................................. 73
13 3D Viewer .................................................................................................................. 74
14 PCB Library Editor .................................................................................................. 76
  14.1 The PCB Library Workspace .......................................................................... 76
  14.2 PCB Library Editor Panel ................................................................................. 77
  14.3 Creating a Component Using the Component Wizard ..................................... 78
  14.4 Manually Creating a Component ..................................................................... 78
  14.5 Copying a Component ..................................................................................... 78
1 PCB Design Process

The diagram above shows an overview of the PCB design process from schematic entry through to PCB design completion.
2 The PCB Editor Workspace

2.1 PCB Editor Panel

The various sections of the PCB editor panel are described below.

2.1.1 Browse Section

This section allows you to list, locate or edit the following PCB object types:

- Nets
- Components
- Libraries
- Component Classes
- Net Classes
- Design Rule Violations
- Design Rules

When you select an object in the Browse section, you can view its location in the workspace in the MiniViewer. Each of the browse functions is described in the following pages.

2.1.2 MiniViewer

This provides an overview of the workspace.

When you are working in the editor workspace, the MiniViewer displays a dashed rectangle to indicate where in the workspace the current display window is.

When objects are selected in the browse section, they are highlighted in the MiniViewer so that you can locate them in the workspace.

The MiniViewer also provides the following display control functions:

- **Panning** Click and drag in the dashed rectangle to pan around the workspace
- **Change View Window** Click and drag on a vertex of the dashed rectangle to change the view window of the workspace
- **Magnifier** Select the Magnifier button and then move the cursor into the main workspace. The MiniViewer displays a magnified view of the cursor location. You can set the magnification level by pressing the Configure button (hint – you can also change the magnification level by pressing the SPACEBAR when the cursor is a magnifying glass).
2.1.3 Current Layer Section

This section indicates the current layer and its colour and allows you to change it.

2.2 Using the Panel to Browse

2.2.1 Browsing Nets

- To browse nets, select Nets in the drop down box. All nets in the PCB are listed in the upper scroll box.

- Click on a net name to select it and all the pads (or nodes) that belong to that net are listed in the lower scroll box. Also, the net is highlighted in the MiniViewer.

- Click on the Edit button to display the Change Net dialog box for the selected net or double-click on the net name.

- Click on the Zoom button to display all the connection lines for the selected net in the workspace.

- In the Nodes section, click on an entry to select a pad in the net.

- Click on the Edit button to display the Change Pad dialog box for the selected pad or double-click on the node name.

- Click on the Jump button to zoom in the selected pad in the workspace.
2.2.2 Browsing Components

- To browse components, select Components in the drop down box. All components in the PCB are listed in the upper scroll box.

- Click on a component name to select it and all the pads that belong to that component are listed (with their net name) in the lower scroll box. Also, the component is highlighted in the MiniViewer.

- Click on the Edit button to display the Change Component dialog box for the selected component or double-click on the component name.

- Click on the Jump button to zoom in on the selected component in the workspace.

- In the Pads section, click on an entry to select a pad in the component.

- Click on the Edit button to display the Change Pad dialog box for the selected component or double-click on the pad name text.

- Click on the Jump button to zoom in on the selected pad in the workspace.
2.2.3 Browsing Libraries

- To browse libraries, select Libraries in the drop down box. All libraries in the current library list are listed in the upper scroll box.

- Click on a library name to select it and all the components that belong to that library are listed in the lower scroll box.

- Click on the Add/Remove button to display the PCB Libraries dialog box to add or remove libraries from the current library list.

- Click on the Browse button or double-click on the library name to display the Browse Libraries dialog box.

- In the Components section, click on an entry to select a component in the library. That component is displayed in the MiniViewer.

- Click on the Edit button to switch to the Library Editor to edit that component.

- Click on the Place button to place the selected component in the workspace or double-click on the component name.
2.2.4 Browsing Net Classes

- To browse net classes, select Net Classes in the drop down box. All net classes in the PCB are listed in the upper scroll box.

- Click on a net class name to select it and all nets that belong to that net class are listed in the lower scroll box.

- Click on the Edit button to display the Edit Net Class dialog box for the selected net or double-click on the net class name.

- In the Nets section, click on an entry to select a net. The net is highlighted in the MiniViewer.

- Click on the Edit button to display the Edit Net dialog box for the selected net or double-click on the net name.

- Click on the Focus button to put the selected net into focus.
2.2.5 Browsing Component Classes

- To browse component classes, select Component Classes in the drop down box. All component classes in the PCB are listed in the upper scroll box.

- Click on a component class name to select it and all nets that belong to that net class are listed in the lower scroll box.

- Click on the Edit button to display the Edit Component Class dialog box for the selected component class or double-click on the component class name.

- In the Components section, click on an entry to select a component. The component is highlighted in the MiniViewer.

- Click on the Edit button to display the Change Component dialog box for the selected component or double-click on the component name.

- Click on the Jump button to zoom in on that component in the workspace.
2.2.6 Browsing Design Rule Violations

- To browse DRC Violations, select Violations in the drop down box. All violation types in the PCB are listed in the upper scroll box.

- Click on a violation type and all violations of that type are listed in the lower scroll box.

- Click on the Details button or double-click on the violation to display the Violation Details dialog box for the selected violation.

- Click on the Highlight button to locate the violation in the workspace.

- Click on the Jump button to zoom in on that violation in the workspace.
2.2.7 Browsing Design Rules

To browse Design Rules, select Rules in the drop down box. All Rule Classes are listed in the upper scroll box.

Click on a Rule Class and all rules defined for that class are listed in the lower scroll box.

Click on the Edit button or double-click on the rule to display a dialog box to edit the selected violation.

Click on the Select button to select all objects affected by the selected rule.

Click on the Highlight button to highlight all objects affected by the selected rule.

2.2.8 Exercises – Using the MiniViewer

1. In the Show/Hide tab of the Preferences dialog box (shortcut keys OD) turn on the Show Pad Nets and Show Pad Number options.

2. Choose the Fit Board view command.

3. Use the MiniViewer Magnifier to display the number and net information of pads.

4. Now, browse each object type and explore the options
2.3 Preferences Dialog Box

The Preferences dialog box allows you to set up parameters relating to the PCB editor workspace. This dialog box is displayed using the Tools » Preferences menu command. Settings in this dialog box remain the same when you change active PCB files. The dialog box has 6 tabs. The options in each of the tabs are described below:

2.3.1 Options Tab

![Options Tab of the Preferences dialog box](image)

**Editing options section**

**Online DRC**
When checked, any design rule violations are flagged as they occur. The design rules are defined in the Design Rules dialog box (select the Design » Rules menu command).

**Snap to Centre**
When checked, the cursor snaps to the centre when moving a free pad or via; snaps to the reference point of a component; snaps to the vertex when moving a track segment.

**Extend Selection**
Selection is cumulative with this option enabled. With it disabled all currently selected objects are de-selected each time a new selection is made.
Remove Duplicates
With this option enabled a special pass is included when data is being prepared for output. This pass checks for and removes duplicate primitives from the output data.

Confirm Global Edit
Displays a dialog box reporting the number of objects that will be altered by the global edit and allows you to cancel.

Protect Locked Objects When checked, locked objects cannot be edited.

Other section

Rotation Step
When an object that can be rotated is floating on the cursor, press the spacebar to rotate it by this amount in an anti-clockwise direction. Hold the shift key whilst pressing the spacebar to rotate it in a clockwise direction.

Undo/Redo
This sets the undo stack size.

Cursor Type
Set the cursor to small or large 90 degree cross, or small 45 degree cross.

Autopan options section

Style
If this option is enabled, auto pan becomes activated when there is a cross hair on the cursor. There are four Auto pan modes:

- *Re-Centre* - re-centres the display around the location where the cursor touched the Window edge. It also holds the cursor position relative to its location on the board, bringing it back to the centre of the display.

- *Fixed Size Jump* - pans across in steps defined by the Step Size. Hold the Shift key to pan in steps defined by the Shift Step Size.

- *Shift Accelerate* - Pans across in steps defined by the Step Size. Hold the Shift key to accelerate the panning up to the maximum step size, defined by the Shift Step Size.

- *Shift Decelerate* - Pans across in steps defined by the Shift Step Size. Hold the Shift key to decelerate the panning down to the minimum step size, defined by the Step Size.

- *Ballistic* – Pans at maximum speed

- Adaptive – Pans at the rate set in the Speed field

Speed
Sets the panning speed for Auto-panning.
Interactive Routing section

Mode
This drop down box has three options as follows:

- **Ignore Obstacle** - If you select this option you can place tracks anywhere in the workspace. If the Online DRC feature is enabled clearance violations are flagged immediately.

- **Avoid Obstacle** - If you select this option you can only place tracks where they do not violate any design rules. This feature is particularly useful when using interactive routing as it allows you to route hard up against existing objects, without fear of violating any clearance rules.

- **Push Obstacle** - If you select this option the editor will attempt to move tracks out of the way so that you can route the current track.

Plough Through Polygons
Marking this check box allows you to override the design rules so that the interactive routing command can route within the area of a polygon.

Automatically Removal Loops
With this option enabled, loops that are created during manual routing are automatically removed.

Polygon Repour
This has three options for determining whether a Polygon repours when edited:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Never</td>
<td>No automatic repour</td>
</tr>
<tr>
<td>Threshold</td>
<td>Prompt of polygon has threshold primitives</td>
</tr>
<tr>
<td>Always</td>
<td>Polygon always repours</td>
</tr>
</tbody>
</table>

Component Drag
This option determines how connected tracks are dealt with when moving a component. When Connected Tracks is selected, tracks drag with the component, otherwise they do not.
2.3.2 Display Tab

Display options

Convert Special Strings
When enabled, Special strings that can be interpreted on screen are displayed. Regardless of this setting, all Special Strings are visible when output is generated.

Highlight in Full
Completely highlights the selected object in the current selection colour. With this disabled the selected object is outlined in the current Selection colour.

Use Net Colour For Highlight
Highlights the selected net in the net colour (assigned in the Change Net dialog box). Use with the Highlight in Full option for better results.

Redraw Layers
Forces a screen redraw as you toggle through layers, with the current layer being redrawn last.

Single Layer Mode
Displays the current layer only. Provides a method of examining what will be output on each layer. If the current layer is a signal layer, multi layer objects are also displayed. Use the “+” and “-” keys to toggle through the layers; press END to redraw the screen. Shift + S also toggles this mode.
**Transparent Layers**

Gives layer Colours a “transparent” nature by changing the colour of an object that overlaps an object on another layer. Allows objects that would otherwise be hidden by an object on the current layer to be readily identified.

**Show section**

The check boxes in this section perform the following when checked:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pad Nets</td>
<td>Displays net names on pads</td>
</tr>
<tr>
<td>Pad Numbers</td>
<td>Displays pin numbers on pads</td>
</tr>
<tr>
<td>Via Nets</td>
<td>Display net names on vias</td>
</tr>
<tr>
<td>Testpoints</td>
<td>****</td>
</tr>
<tr>
<td>Origin Marker</td>
<td>Displays the Origin Marker</td>
</tr>
<tr>
<td>Status Info</td>
<td>Displays information about the object under the cursor in the status bar</td>
</tr>
</tbody>
</table>

**Draft thresholds Section**

**Tracks**

Tracks of the width entered in the check box (or narrower) will be displayed as a single line; tracks of greater width will be displayed as an outline (when tracks are displayed in Draft Mode).

**Strings**

The number entered in this field determines which strings are displayed as text and which are displayed as an outline box.

Strings that are placed at or less than the value stipulated (at the current zoom level) will be displayed as text; strings that are placed at a greater value will be represented by an outline box.

**Layer Drawing Order Button**

The PCB editor allows you to control the order in which layers are re-drawn. Press the Draw Order button to pop up the Layer Drawing Order dialog box. The order that the layers appear in the list is the order that they will re-draw in. The layer at the top of the list is the layer that will appear on top of all other layers on the screen.
2.3.3 Colours Tab

This enables you to set the display colour of each layer in the PCB.

![Figure 3 Colors Tab of the Preferences dialog box](image)

The Default Colors button sets the colors the default setting. The Classic Colors button sets the colours to the default setting of Advanced PCB version 2.
### 2.3.4 Show/Hide Tab

This dialog box enables you to control which object types get displayed and how they are displayed.

![Figure 4 Show/Hide tab of the Preferences Dialog box](image)

*Figure 4 Show/Hide tab of the Preferences Dialog box*
2.3.5 Default Primitives Tab

This enables you to set the default properties for each object type in the PCB editor. Figure 11 below shows the default setting for a track.

![Figure 5 Defaults Tab](image)

If the permanent check box is not checked, the settings in this dialog box will change when you change the properties of an object being placed.
2.3.6 Signal Integrity Tab

To insure the accuracy of the signal integrity analysis you need to define the appropriate component types.

Steps:
1. Click on the Add button to display the Component Type dialog box.
2. Enter the designator prefix (e.g. R) in the Designator Prefix field.
3. Click on the down arrow in the Component Type field to display drop down menu.
4. Select the appropriate component type (e.g. Resistor).
5. Note! Components which do not have a type assigned are assumed to be of type IC.
2.3.7 Exercises – Exploring the Preferences

1. Open the document Z80 Processor Board.pcb
2. Choose the Options tab of the Preferences dialog box and try the following:
3. Check the single layer mode, click on OK and change active layers by selecting the various layer tabs. Turn single layer mode off
4. Check Transparent Layers then zoom in and view some pads with tracks connected to them. Turn Transparent Layers off.
5. Choose the Colors tab of the Preferences dialog box.
6. Press the Classic button and choose OK.
7. Re-display the dialog box and press the default button and choose OK
8. Experiment with changing the colours of various layers
9. Choose the Show/Hide tab of the Preferences dialog box
10. Observe the effect of pressing the All Draft, All Final and All Hidden buttons
11. Zoom in on a pad and check on and then off the Show Pad Nets and Show Pad Number options.
2.4 Document Options Dialog Box

The Document Options dialog box allows you to set parameters relating to individual PCB documents. This dialog box is displayed using the Design » Options menu command. The settings in this dialog box are saved with the PCB file. The options in the tabs for this dialog box are described below.

2.4.1 Layers Tab

The check boxes in this dialog box allow you to turn on or off the various PCB editor layers.

*Figure 7 Layers tab of the Document Options dialog box*
2.4.2 Options Tab

The options on this tab are described below:

Figure 8 Options Tab of the Document Options dialog box

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap X</td>
<td>X value for the snap grid</td>
</tr>
<tr>
<td>Snap Y</td>
<td>Y value for the snap grid</td>
</tr>
<tr>
<td>Component X</td>
<td>X value for the component grid</td>
</tr>
<tr>
<td>Component Y</td>
<td>Y value for the component grid</td>
</tr>
</tbody>
</table>

**Electrical Grid**

When the electrical grid is enabled, when you are executing a command which supports the electrical grid and you move the cursor within the Grid Range value of an object assigned to a net, the cursor will jump to that object.

**Visible Kind** Sets the style of the visible grid – dots or lines

**Measurement Unit** Sets the coordinate system to either metric or imperial.

2.5 The PCB Coordinate System

The PCB editor has a coordinate system with the origin located in the bottom left hand corner of the workspace. This point has the coordinates of (0,0) and is known as the Absolute Origin. The workspace size is 100 inches by 100 inches. The reference point of the coordinate system can be re-defined at any time using the Edit » Origin » Set menu command and this sets what is known as the Origin. The coordinate read out in the status bar gives the coordinates relative to the Origin. The Edit » Origin » Reset menu command sets the Origin to the Absolute Origin.
There is an Origin Marker that shows the location of the Current Origin. This is displayed by checking the Display Origin Marker check box in the Show/Hide tab of the Preferences dialog box.

The coordinate system units can be either metric or imperial. The View » Toggle Units menu command or the Q shortcut key toggles the coordinate system between metric and imperial.

2.6 Grids

2.6.1 Snap Grid

The Snap Grid ensures accurate movement and placement of objects. The Snap grid causes the coordinates of a mouse click to snap to the nearest snap grid point. The Snap grid has X and Y values and is set on the Options tab of the Document Options dialog box. (Design » Options menu command)

2.6.2 Visible Grid

The Visible Grid displays either as lines or dots when turned on. This is independent of the Snap Grid. The PCB editor has two visual grids that you can set and display independently. The Visible Grids are set and they are turned on or off in the Layers tab of the Document Options dialog box.

2.6.3 Electrical Grid

The Electrical Grid setting defines the range within which the cursor will override the snap grid to jump to another object, such as a via, pad or track when in the interactive routing command. When the Electrical Grid overrides the Snap Grid, an octagon displays on the cursor. When you see that octagon, you know that the cursor is precisely located on the object it has jumped to.

The Electrical Grid is set and turned on or off in the Options tab of the Document Options dialog box (Design » Options menu command or OB).

2.6.4 Component Grid

The component Grid is similar to the Snap Grid except that it is only active when placing or moving components. The Component grid has X and Y values and is set in the Options tab of the Document Options dialog box (Design » Options menu command or OB).
2.7 Shortcut Keys for Setup Options

Pressing the O shortcut key displays a menu that provides a quick way of accessing the set up dialog boxes. The options in this menu are described below:

<table>
<thead>
<tr>
<th>Option</th>
<th>Dialog Box displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Board Options</td>
<td>Options tab of Document Options</td>
</tr>
<tr>
<td>Board Layers</td>
<td>Layers tab of Document Options</td>
</tr>
<tr>
<td>Mechanical Layers</td>
<td>Setup Mechanical Layers</td>
</tr>
<tr>
<td>Netlist Manager</td>
<td>Netlist Manager</td>
</tr>
<tr>
<td>Layer Stack Manager</td>
<td>Layer Stack Manager</td>
</tr>
<tr>
<td>Classes</td>
<td>Object Classes</td>
</tr>
<tr>
<td>From-To Editor</td>
<td>From-To Editor</td>
</tr>
<tr>
<td>Preferences</td>
<td>Preferences with the last tab used as the active tab</td>
</tr>
<tr>
<td>Display</td>
<td>Layers tab of Preferences</td>
</tr>
<tr>
<td>Colors</td>
<td>Colors tab of Preferences</td>
</tr>
<tr>
<td>Show/Hide</td>
<td>Show/Hide tab of Preferences</td>
</tr>
<tr>
<td>Defaults</td>
<td>Defaults tab of Preferences</td>
</tr>
<tr>
<td>Signal Integrity</td>
<td>Signal Integrity tab of Preferences</td>
</tr>
</tbody>
</table>

2.7.1 Exercises – Exploring the Document Options

1. Choose the Layers Tab of the Document Options dialog box located in the Design menu.
2. Experiment with the Used on, All On and All Off buttons and with turning on and off individual layers.
3. Choose the Options Tab of the Document Options dialog box.
4. Experiment with changing the various grid settings.
3 Creating a New PCB

3.1 Printed Circuit Board Wizard

When you select **File » New** in the PCB editor, the Select Document Type dialog box is displayed. If you want to create an empty PCB file, choose the PCB Icon on the Blank Document tab. If you wish to use the Printed Circuit Board Wizard, choose the Document Wizards tab and then select Printed Circuit Board Wizard to display the Board Wizard. This takes you through a series of steps. You can select from a range of standard PCB formats and set up design rules for the technology you will be using on that PCB. There is also an option for custom PCB’s.

![Figure 9 Board Wizard](image)

*Figure 9 Board Wizard*
4 Transferring Design Information to the PCB

The Synchronizer is a tool that allows the transfer of design information between the Schematic and the PCB documents as follows:

**Schematic to PCB**: Component and connectivity information from the schematic is transferred to the PCB.

**PCB to Schematic**: If the designators of any PCB components are edited, or the Re-Annotate command is executed, the schematic is automatically updated with the new designators.

You run the Synchronizer once the schematic is finished to transfer design information to the PCB and to place components. You also run the Synchronizer to update the PCB with any changes that have been made to the schematic after the initial Synchronization has been performed.

4.1 Design Synchronization

To synchronize the PCB, select the Design > Update PCB menu command in the Schematic Editor. This displays the Update Design dialog box shown below.

![Update Design dialog box](image)

*Figure 10 Update Design dialog box*
Choose the appropriate options for your project in the Connectivity section.

- The Assign Net to Connected Copper option updates the routing net names to match the net names of the connected pads.
- The options in the Components section are applicable when Synchronizing a previously placed PCB.
- The Rules section allows you to control how PCB design rules are created from Layout Directives in the schematic.
- The Synchronization process then analyses both the schematic and any PCB objects present in the PCB document. For each difference detected between the schematic and the existing PCB, a Macro is created. This macro tells the PCB editor what action must be performed to update the PCB document to match the schematic.
- If you are Synchronizing a new design, macros are created for the entire schematic. If you are updating your design, macros are created for each design change.
- If there is a condition in either the schematic or the PCB file, which prevents the Synchronizer from generating a macro for a particular action, an error results. Errors are listed in the Error column on the Changes tab of the Update Design dialog box. The number of errors is shown in the Status field at the bottom of the dialog box.
- To perform the actual loading of schematic data into the PCB file, i.e. to run the macros, click on the execute button. Macros with errors do not execute.

4.2 Resolving Synchronization Errors

The table below explains the cause of each of the possible Synchronization errors:

<table>
<thead>
<tr>
<th>Error</th>
<th>A Macro is attempting to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Net not found</td>
<td>Add or remove a node; remove a net; or change a net name when that net cannot be found in the PCB document.</td>
</tr>
<tr>
<td>Component not found</td>
<td>Add or remove a node when the component designator is incorrectly specified in the Macro or the component cannot be found in the PCB document; remove a component; or change a footprint, designator or comment when the component cannot be found in the PCB document.</td>
</tr>
<tr>
<td>Node Not found</td>
<td>Add or remove a node from a component that does not have that pin; or remove a node that does not exist in the specified net.</td>
</tr>
<tr>
<td>Net already exists</td>
<td>Add a net name when a net with that name already exists in the PCB document.</td>
</tr>
<tr>
<td>Component already exists</td>
<td>Add a component when a component with that designator already exists in the PCB document.</td>
</tr>
<tr>
<td>New footprint not matching old footprint</td>
<td>Change a component footprint when the used pins on the old footprint do not match the used pins on the new footprint. This can occur if the new component has fewer pins than the old, or if the pin numbering in the schematic, is different to the pin numbering on the footprint.</td>
</tr>
<tr>
<td>Error</td>
<td>A Macro is attempting to:</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Footprint not found in Library</td>
<td>Add a new component or change a component footprint when the specified footprint could not be found in any of the libraries in the current library list and no alternative library reference could be found in the Cross Reference file (See 4.5.3).</td>
</tr>
<tr>
<td>Alternative footprint used instead (warning)</td>
<td>Add a new component or change a component footprint when the specified footprint could not be found in any of the libraries in the current library list, but it has found an alternative in the Cross Reference File (See 4.5.3)</td>
</tr>
</tbody>
</table>

### 4.3 Summary

Most problems with Synchronizing a design generally fall into two categories.

1. Component footprints - missing components occur when: a footprint is missing from the component information in the schematic; you have forgotten to add the required PCB libraries to the current library list ([Design » Add/Remove Library](#) or Add/Remove Button on the PCB Editor panel); or the footprint in the schematic does not match any PCB library component.

2. New footprint not matching old footprint - the cause is usually that the pin numbering on the schematic component differs from the pin numbering on the PCB footprint.

### 4.4 Cross Reference File

When a Macro attempts to load or change a component footprint that cannot be located in any of the libraries, it then uses the component Comment to look-up the Cross Reference file (ADVPCB.XRF in `\Design Explorer 99 SE\System directory`). The Cross Reference file lists components by their type against any appropriate footprint(s) for that component. For example, if the component U1 was a 74LS00, but you had forgotten to include the footprint, when the Macro to add this component was validated it would look-up 74LS00 in the XRF file. 74LS00 has DIP14 as a footprint, which would be loaded from one of the libraries in the current library list.
4.5 Design Transfer Using a Netlist

For most situations, the Synchronizer has superseded Netlist loading. In cases where the PCB is being designed from a schematic drawn on another EDA vendor’s schematic editor, a netlist can be used.

Netlist loading is a method by which connectivity and component information are transferred to the PCB Editor via a netlist. If the netlist load is successful, the PCB file will contain all components ready to be placed within the PCB outline.

Netlist loading is performed on a new PCB file once the schematic is complete and the netlist generated. It is also performed whenever design changes have been made to the schematic which then need to be propagated the PCB layout. Netlist loading is also referred to as Forward Annotation.

4.5.1 Loading a Netlist

To load a netlist select the Design » Load Nets menu command. This displays the Load/Forward Annotate Netlist dialog box shown below.

![Load/Forward Annotate Netlist dialog box](image.png)

Figure 11 Load/Forward Annotate Netlist dialog box
• Click on the Browse button, locate and select the netlist file to be loaded.

• The netlist loading process then analyses both the netlist and any PCB design data present in the workspace. For each difference detected between the netlist and the existing design data, a Netlist Macro is created. This macro tells the PCB editor what action must be performed to update the design data to match the netlist.

• If you are loading a netlist for the first time, Netlist Macros will be created for the entire netlist. If you are forward annotating your design, Netlist Macros are created for each design change.

• If there is an condition in either the netlist or the PCB file which prevents the netlist loading process from generating a macro for a particular action, an error results. Errors are listed in the Error column on the Load/Forward Annotate Netlist dialog box. The number of errors resulting from a netlist load is shown in the Status field at the bottom of the dialog box.

• To perform the actual loading of netlist data into the PCB file, click on the execute button. It is unwise to execute the netlist loading while there are macro errors and hence these should be resolved before proceeding.

4.5.2 Resolving Netlist Loading Errors

The table below explains the cause of each of the possible Netlist Loading errors:

<table>
<thead>
<tr>
<th>Error</th>
<th>A Netlist Macro is attempting to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Net not found</td>
<td>Add or remove a node; remove a net; or change a net name when that net cannot be found in the PCB netlist.</td>
</tr>
<tr>
<td>Component not found</td>
<td>Add or remove a node when the component designator is incorrectly specified in the Macro or the component cannot be found in the PCB netlist; remove a component; or change a footprint, designator or comment when the component cannot be found in the PCB netlist.</td>
</tr>
<tr>
<td>Node Not found</td>
<td>Add or remove a node from a component that does not have that pin; or remove a node that does not exist in the specified net.</td>
</tr>
<tr>
<td>Net already exists</td>
<td>Add a net name when a net with that name already exists in the PCB netlist.</td>
</tr>
<tr>
<td>Component already exists</td>
<td>Add a component when a component with that designator already exists in the PCB netlist.</td>
</tr>
<tr>
<td>New footprint not matching old footprint</td>
<td>Change a component footprint when the used pins on the old footprint do not match the used pins on the new footprint. This can occur if the new component has fewer pins than the old, or if the pin numbering in the netlist (which comes from the schematic component pin numbers) is different to the pin numbering on the PCB component.</td>
</tr>
</tbody>
</table>
Footprint not found in Library | Add a new component or change a component footprint when the specified footprint could not be found in any of the libraries in the current library list and no alternative library reference could be found in the Cross Reference file (See 4.5.3).

Alternative footprint used instead (warning) | Add a new component or change a component footprint when the specified footprint could not be found in any of the libraries in the current library list, but it has found an alternative in the Cross Reference File (See 4.5.3)

Summary

Most problems with loading a schematic netlist generally fall into two categories.

1. Component footprints - missing components occur when: a footprint is missing from the component information in the netlist; you have forgotten to add the required PCB libraries to the current library list (Design » Add/Remove Library); or the footprint in the netlist does not match any Advanced PCB library component.

2. New footprint not matching old footprint - the cause is usually that the pin numbering on the schematic component differs from the pin numbering on the PCB footprint.

4.5.3 Cross Reference File

When a Netlist Macro attempts to load or change a component footprint that cannot be located in any of the libraries, it then uses the component Comment to look-up the Cross Reference file (ADVPCB.XRF in Design Explorer 99 SE/System directory). The Cross Reference file lists components by their type against any appropriate footprint(s) for that component. For example, if the component U1 was a 74LS00, but you had forgotten to include the footprint, when the Macro to add this component was validated it would look-up 74LS00 in the XRF file. 74LS00 has DIP14 as a footprint, which would be loaded from one of the libraries in the current library list.

4.5.4 Editing Netlist Macros

The Load/Forward Annotate Netlist dialog box provides the capability to edit the netlist macros. If you are driving your design from the schematic via the netlist, you will not need to use these capabilities.

4.5.5 Executing the Netlist Loading

If you have resolved all the netlist macro errors, you can execute the netlist loading by clicking on the Execute button.

This results in all the components to be placed, being placed at the centre of the PCB outline.
5 Setting up the PCB Layers

5.1 Layer Definitions

The PCB Editor has a concept of layers to represent the various elements of a printed circuit board. When placing objects using the PCB editor, you need to consider which layer they are to be placed on. Objects are placed on the Current layer. The display of layers is controlled using the Layers tab of the Document Options dialog box that is displayed by the Design » Options menu command.

The Current Layer is set by any of the following:

- Clicking on the appropriate Layer tab
- Pressing the + or – keys on the numeric pad
- Accessing the drop-down box in the Current Layer section of the PCB Editor panel

Each of the PCB editor layers is described below:

**Signal Layers**

There are 32 signal layers that can be used for track placement. Anything placed on these layers will be plotted as solid (copper) areas on the PCB. As well as tracks, other objects (e.g. fills, text, polygons, etc.) can be placed on these layers. The signal layers are named as follows:

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Top signal layer</td>
</tr>
<tr>
<td>MidLayer1 to MidLayer30</td>
<td>Inner signal layers</td>
</tr>
<tr>
<td>Bottom</td>
<td>Bottom signal layer</td>
</tr>
</tbody>
</table>

Signal layer names are user definable.

**Internal Planes**

Sixteen layers (named Internal Plane 1–16) are available for use as power planes. Nets can be assigned to these layers and multi-layer pads and vias automatically connect to these planes. Internal Plane layer names are user definable.

**Silkscreen**

Top and Bottom Silkscreen layers are typically used to display component outlines and component text (designator and comment fields that are part of the component description).

**Mechanical Layers**

Sixteen mechanical drawing layers are provided for fabrication and assembly details such as dimensions, alignment targets, annotation or other details. Mechanical layer items can be automatically added to other layers when printing or plotting artwork. Mechanical Layer names are user definable.
Solder Mask

Top and bottom masks are provided for creating the artwork used to make the solder masks. These automatically generated layers are used to create masks for wave soldering, usually covering everything except component pins and vias. You can control the expansions for these masks when printing/plotting by including a Solder Mask Expansion rule. Refer to the Design Rules section for more information on the Solder Mask Expansion rule.

Paste Masks

Top and bottom masks are provided to generate the artwork which is used to manufacture stencils to deposit solder paste onto surface mount pads on PCB’s with surface mount devices (SMDs). Refer to the Design Rules section for further information.

Drill Drawing

Coded plots of board hole locations typically used to create a drilling drawing that shows a unique symbol for each hole size at each hole location. Individual layer pair plots are provided when blind/buried vias are specified. Three symbol styles are available: coded symbol, alphabetical codes (A, B, C etc.) or the assigned size.

Drill Guide

Plots of all holes in the layout - sometimes called pad masters. Individual layer pair plots are provided when blind/buried vias are specified. These plots include all pads and vias with holes greater than zero (0) size.

Keep Out

This layer is used to define the regions where components and routes can validly be placed. For example, the board boundary can be defined by placing a perimeter of tracks and arcs, defining the region within which all components and tracks must be placed. “No-go” areas for components and tracks can be created inside this boundary by blocking off regions with tracks, arcs and fills. Keep outs apply to all copper layers. The basic rule is; components can not be placed over an object on the Keep Out layer and routes can not cross an object on the Keep Out layer.

Multi Layer

Objects placed on this layer will appear on all copper layers. This is typically used for through hole pads and vias, but other objects can be placed on this layer.
Display Layers

The layers described below cannot have objects placed on them but they are turned on or off in the Design-Options dialog box.

DRC Errors

This option controls the display of the Design Rule Check (DRC) error marker.

Visible Grids

Controls the display of the two visible grids.

Pad and Via Holes

Controls the display of pad and via holes. To be able to distinguish pads from vias in draft mode, pad holes are outlined in the current Pad Holes colour (set in the Colours Tab of the Preferences dialog box).

Connect

This option controls the display of the connection lines. The PCB editor displays connection lines wherever it locates part of a net that is un-routed.
5.2 Layer Stack Manager

The Layer Stack Manager provides an easy to use, graphical method of defining, naming and editing layers. It is displayed by selecting the Design » Layer Stack Manager menu command (DK).

![Layer Stack Manager Diagram](image)

Figure 12 Layer Stack Manager

The Layer Stack Manager allows you visually see the “stack up” of your PCB, i.e. the relationship between copper, substrate and prepreg.

Adding a Signal Layer

To add a layer to your PCB, click on the name text of an existing layer displayed in the Layer Stack Manager and the click on the Add Layer button or right click and choose Add Signal Layer from the right click menu. This procedure adds a new layer with a default name allocated to it. Double-clicking on the name text for that layer enables you to edit the name or the copper thickness of that layer.

Adding An Internal Plane Layer

To add an Internal Plane layer to your PCB, click on the name text of an existing layer adjacent to where you want the plane inserted then click on the Add Plane button or right click and choose Add Internal Plane Layer from the right click menu. This procedure adds a new internal plane layer with a default name allocated to it. Double-click on the name text for that internal plane layer to edit the name, the copper thickness or net name for that layer.
**Insulation Layers**

As additional layers are added to the PCB, insulation layers are automatically added. The insulation layer can either be Core or Prepreg and this is determined by the “Stack Up” style setting. Double-clicking on the name text sets the properties of the insulation layers. These properties are material, thickness and Dielectric constant. The Signal Integrity software uses these properties.

**Deleting a Layer**

To delete a layer, click on the name text of an existing layer and then click on the Delete button or right click and choose delete from the right click menu.

**Editing the “Stack Up” Order**

To change the order in which layers are defined in your PCB, click on the name of the layer and click on the Move Up or Move Down buttons or Right Click and choose Move Up or Move Down from the right click menu.

**Editing the “Stack up” Style**

The “Stack Up” style defines the order in which the PCB substrate, copper and prepreg insulation layers are fabricated as well as the finish on the PCB. The Style is set in the top left hand corner of the Layer Stack Manager. The “Stack up” is specified in the drop down box. The choices are:

- Layer Pairs
- Internal Layer Pairs
- Build Up

The board finish is defined by selecting the buttons next to the Top and Bottom Dielectric check boxes. Click on these to set the material, thickness and dielectric constant for the finish.

**Drill Pairs**

The term Drill Pairs refers to the two layers that a drilling operation starts from and finishes at. By default Drill Pairs are defined as Top and Bottom Layers. If blind or buried vias are to be used on your PCB, Layer Pairs must be defined for these. Pressing the Drill Pairs button performs this.
5.3 Defining Mechanical Layers

Before a Mechanical Layer can be used it must be enabled in the Setup Mechanical Layers dialog box that is displayed by selecting the **Mechanical Layers** command in the **Design** menu. Marking an Enabled check box enables a Mechanical Layer. Once enabled, the layer name is displayed and can be edited.

![Setup Mechanical Layers Dialog Box](image)

**Figure 13 Setup Mechanical Layers Dialog Box**

The visible check box allows you to control the display of its mechanical. When checked, the Display In Single Layer Mode check box causes its layer to be displayed when Single Layer Mode is invoked (Shift S).
5.4 Internal Power Planes

General Notes

The PCB Editor allows for up to sixteen power planes.

A power plane is defined by assigning a net to an internal plane layer.

The PCB editor automatically connects pins that belong to the power plane net and isolates all other pins from the plane.

Internal power planes are output as photographic negatives (compared to other layers which are output as positives).

5.4.1 Defining an Internal Power Plane

An internal power plane is added, named and assigned to a net using the Layer Stack Manager.

When a net has been assigned to an internal plane layer, pins in that net automatically connect to that plane layer using thermal relief connections. The style of these is defined in the Power Plane Connect Style rule class in the Manufacturing tab of the Design Rules dialog box. Nets, which are not connected to the plane, are isolated from it by a clearance which is defined in the Power Plane Clearance rule class in the Manufacturing tab of the Design Rules dialog box.

5.4.2 Defining a Split Power Plane

Internal power planes have the capability to have multiple nets on the same Internal plane layer by using the Split Planes object. The additional nets must be within enclosed areas on the internal plane as shown in Figure 14.

![Figure 14 Split Plane Example](image-url)
To define a Split Plane, select the **Place » Split Plane** menu command. This displays the Split Plane dialog box shown in Figure 15 where you enter the track width, internal plane layer and net for the split plane. The track width you key in is actually the width of the isolation region between the internal plane net and split plane net.

![Split Plane dialog box](image)

**Figure 15** Split Plane dialog box

**Tip:** To help ensure that you enclose all the required pins in the split plane; you can change the colour of the split plane net. Use the Browse Net function on the PCB Editor panel and then use the **Select » Physical Net** menu command to display the pins with their net colour.

### 5.4.3 Moving and Editing Split Plane Vertices

You can move the split plane by clicking and holding on the split plane track and moving it to a new position. You can move and insert vertices on the split plane using the **Edit » Move » Split Plane Vertices** menu command.

### 5.4.4 Deleting a Split Plane

To delete a split plane, select the **Edit » Delete** command and then click on the split plane to be deleted.
5.4.5 Exercises – Setting up the PCB Layers

Assigning an Internal Plane

1. Open the document Z80 Processor Board.pcb
2. Using the Design » Layer Stack Manager menu command, assign the net GND to Internal Plane 1. Observe the connection lines for the GND net when you do this.
3. Turn all layers off except Internal Plane 1 and zoom in on pins that belong to the GND net.
4. Placing a Split Plane for the +12V Net
5. So that the +12V pads can be seen, use the Net browser in the PCB editor panel to edit the net +12V and change its colour to a unique colour.
6. In the Options tab of the Preferences dialog box, turn on the Use Net Colour For Highlight option and then select the Edit » Select » Physical Connection menu command - You shouldn’t see the +12V pads shown in a different colour to the rest of the pads.
7. Place a +12V split plane on Internal Plane 1 (make sure to enclose some +12V pads)
8. Now move the split plane so that it encloses a GND pad. Observe that the GND enclosed GND pad becomes isolated from the +12V copper.
9. Use Edit » Delete to delete the split plane. Note the effect on the +12V pads.
6 Setting Up Design Rules

General Notes

Traditionally, the term Design Rules referred to PCB editor functions that ensured that your design complied with predetermined manufacturing requirements (e.g. minimum clearances in copper). In addition, they were applied globally to the PCB.

In recent times, Protel has expanded the concept of Design Rules. They now apply to every aspect of the PCB design and optionally to specific objects as well as globally.

This section describes how Design Rules are defined. The following section describes how to check for design rule violations.

6.1 Adding Design Rules

Design rules are defined in the Design Rules dialog box that is displayed by selecting the Design » Rules menu command.

![Design Rules dialog box](image)

Figure 16 Design Rules dialog box

To set up a design rule:

- Click on the tab to select the general category for the rule
- In the Rule Classes list, single click on a specific rule to display a definition of the rule
- Double-click on a specific rule to display the dialog box where you can set the Rule Scope and Rule Properties for that rule.

To see the objects affected by a rule, click on the Select Affected Objects button at the bottom of the Design Rules dialog box. This selects the affected objects.
To effectively apply the Design Rules, the concepts of Object Set, Scope, Rule Type and Precedence need to be understood. These are described in the following sub-sections.

### 6.2 Object Set

This refers to the object or group of objects a rule applies to. The Object Set can be a single object or a group of objects determined by the Rule Scope.

### 6.3 Rule Type

There are two types of Design Rules as follows:

<table>
<thead>
<tr>
<th>Unary Design Rules</th>
<th>Binary Design Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>These apply to one object, or each object in a set of objects</td>
<td>These apply between two objects, or between any object in one set to any object in the second set.</td>
</tr>
<tr>
<td>e.g. Solder Mask Expansion</td>
<td>e.g. Clearances, which apply between any copper object in the first set and any copper object in the second set, as identified by the two rule scopes.</td>
</tr>
<tr>
<td>Unary rules have one section on the left hand side of the Edit Rule tab of their dialog box.</td>
<td>Binary rules have two sections on the left hand side of the Edit Rule tab of their dialog box designated A and B.</td>
</tr>
</tbody>
</table>

### 6.4 Scope

This allows you to determine how the rule is applied. Some rules do not support all Scopes. The options for scope are:

<table>
<thead>
<tr>
<th>Scope</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>A rectangle within the board area defined by diagonal coordinates</td>
</tr>
<tr>
<td>Pad</td>
<td>A specific pad on the board (e.g. U2-4)</td>
</tr>
<tr>
<td>Pad Specification</td>
<td>Pads defined by their properties (e.g. size, hole size, net)</td>
</tr>
<tr>
<td>Pad Class</td>
<td>A user defined group of Pads</td>
</tr>
<tr>
<td>Via Specification</td>
<td>Vias defined by their properties (e.g. diameter, hole size)</td>
</tr>
<tr>
<td>From-To</td>
<td>A specific connection from one pad to another (Defined in Design » From-To Editor menu)</td>
</tr>
<tr>
<td>From-To Class</td>
<td>A user defined group of From-To’s (Defined in Design » Classes menu)</td>
</tr>
<tr>
<td>Footprint</td>
<td>A specific library component designated by footprint</td>
</tr>
<tr>
<td>Footprint Pad</td>
<td>A specific pad of a footprint</td>
</tr>
<tr>
<td>Net</td>
<td>A specific net</td>
</tr>
<tr>
<td>Net Class</td>
<td>A user defined group of nets (Defined in Design » Classes menu)</td>
</tr>
<tr>
<td>Component</td>
<td>A specific component</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>Component Class</td>
<td>A user defined group of components (Defined in <strong>Design » Classes</strong> menu)</td>
</tr>
<tr>
<td>Object Kind</td>
<td>A type of primitive object</td>
</tr>
<tr>
<td>Layer</td>
<td>A routing layer (Top, mid 1-30 or bottom)</td>
</tr>
<tr>
<td>Whole Board</td>
<td>Applies to the complete PCB design</td>
</tr>
</tbody>
</table>

Multiple Scopes can be applied to the same Object Set by clicking on the And tab for the Object Set

### 6.5 Precedence

Through the use of different scopes it is possible to have conflicting rules applied to the same object. There is an order of precedence of scope that applies to resolve these conflicts. The order of precedence of scope is listed below:

- Region (highest priority)
- Pad
- Footprint-pad
- Via Specification
- Pad specification
- Pad class
- From-To
- From-To Class
- Net
- Net Class
- Component
- Component Class
- Footprint
- Object Kind
- Layer
- Whole Board (lowest priority)
## 6.6 Where Rules Apply

### 6.6.1 Routing Rules

<table>
<thead>
<tr>
<th>Rule Class</th>
<th>Place Track</th>
<th>Auto Route</th>
<th>On-Line DRC</th>
<th>Batch DRC</th>
<th>Output Generation</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clearance Constraint</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td>Place Polygon</td>
</tr>
<tr>
<td>Routing Corners</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Routing Layers</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Routing Priority</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Routing Topology</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Routing Via Style</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SMD Neckdown Constraint</td>
<td></td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SMD To Corner Constraint</td>
<td></td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SMD To Plane Constraint</td>
<td></td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Width Constraint</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### 6.6.2 Manufacturing Rules

<table>
<thead>
<tr>
<th>Rule Class</th>
<th>Auto Route</th>
<th>On-Line DRC</th>
<th>Batch DRC</th>
<th>Output Generation</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acute Angle Constraint</td>
<td></td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hole Size Constraint</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Layer Pairs</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td>Place Track</td>
</tr>
<tr>
<td>Minimum Annular Ring</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste Mask Exp</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
</tr>
<tr>
<td>Polygon Connect Style</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Place Polygon</td>
</tr>
<tr>
<td>Power Plane Clearance</td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Power Plane Connect Style</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Internal Planes</td>
</tr>
<tr>
<td>Solder Mask Exp</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
</tr>
<tr>
<td>Testpoint Style</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Find Testpoint</td>
</tr>
<tr>
<td>Testpoint Usage</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Find TestPoint</td>
</tr>
</tbody>
</table>
### 6.6.3 High Speed Rules

<table>
<thead>
<tr>
<th>Rule Class</th>
<th>Auto Route</th>
<th>On-Line DRC</th>
<th>Batch DRC</th>
<th>Output Generation</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daisy Chain Stub Length</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Length Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Matched Length Nets</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td>Equalise Net Lengths command</td>
</tr>
<tr>
<td>Maximum Via Count Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parallel Segment Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vias Under SMD constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### 6.6.4 Placement Rules

<table>
<thead>
<tr>
<th>Rule Class</th>
<th>Auto Route</th>
<th>On-Line DRC</th>
<th>Batch DRC</th>
<th>Output Generation</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Clearance Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td>Auto Place</td>
</tr>
<tr>
<td>Component Orientation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Auto Place</td>
</tr>
<tr>
<td>Nets To Ignore</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Auto Place</td>
</tr>
<tr>
<td>Permitted Layers</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Auto Place</td>
</tr>
<tr>
<td>Room Definition</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### 6.6.5 Signal Integrity Rules

All Signal Integrity rule apply only to Signal Integrity Analysis

### 6.6.6 Other Design Rules

<table>
<thead>
<tr>
<th>Rule Class</th>
<th>Auto Route</th>
<th>On-Line DRC</th>
<th>Batch DRC</th>
<th>Output Generation</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short Circuit Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Un-Connected pin Constraint</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Un-routed Net Constraint</td>
<td>Y Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
6.7 Additional Information on Rules

SMD to Corner Constraint

This rule specifies the minimum distance that should be allowed from the centre of a surface mount pad to the first vertex of a track routed to that pad.

Width Constraint

This rule allows you to apply and maximum and minimum track width to tracks determined by the scope selected. When this rule is applied, it overrides the default track width.

Matched Length Nets Rule

This rule can be applied to Net Classes and From-To Classes. When applied, it determines the longest Net or From-To in the class and sets any that fall outside the tolerance as violations. The violations can be automatically corrected using the Tools » Equalize Net Lengths command. This command attempts to lengthen nets in violation by inserting “accordion” sections to the track provided it does not violate Clearance Constraint design rules.

![Matched Lengths Rule Dialog Box](image)

Figure 17 Matched Lengths Rule Dialog Box

Short Circuit Constraint

This rule allows you to overrule the short circuits by specifying Nets or Net Classes that can be connected together. This rule is provided to allow for situations where a mixed signal PCB has multiple ground signals that must be connected together at one point on the PCB.
6.8 Object Classes

6.8.1 Defining Classes

Classes are provided to enable various commands to operate on sub-sets of object types. eg, a group of components.

Commands will operate on a class if a design rule for that class has been defined.

Classes can be applied to:

- Nets
- Components
- Pads
- From to’s

To assign an object type to a class, choose the Design » Classes menu command. This displays the Object Classes dialog box shown in Figure 18 below.

Click on the tab for the object type you want to assign and press the Add button. This displays a dialog box such as the Edit Component Class dialog box shown below. You enter a new name for the class to be defined in the Class Name field. The Non-Members scroll box lists all the objects (of that object type) in the PCB file. Objects are assigned to the class by clicking on the object name and then pressing the > button which transfers the object name to the Members scroll box. Objects can be removed from the class by click on the name in the Members scroll box and pressing the < button.

![Figure 18 Assigning Object Classes](image-url)
Once classes have been defined, objects can be added or removed by clicking on the class name and pressing the Edit button on the Object Classes dialog box and Classes can be deleted press the Delete button.

Any object of a particular type can belong to more than one class.

Each Object Class tab provides the option to add or remove objects from a class based on selection.

Also, objects can be selected by Class by clicking on the Select push button.

6.8.2 Component Class Generator

The Edit Component Class dialog box has the Class Generator button. When clicked, the Component Class Generator dialog box displays.

This allows you to define a component class containing components based properties selected properties.
6.9 From To’s

The PCB editor provides the capability of having commands operate on a particular pin-to-pin connection in a net, in a different manner to the rest of the net. A specific pin-to-pin connection is defined as a From-To. Commands will operate on a From-To if a design rule for that From-To has been defined.

A From-To is defined using the From-To Editor that is invoked using the Design » From-To Editor menu command. This displays the From-To Editor shown in Figure 19.

![Figure 19 From-To Editor](image)

From the net you want to assign From-To’s in, you click on that net name in the drop down box in the net section, this displays the pads assigned to that net in the graphical window. The display colour of the pads shows their electrical type.

To assign a from-to, click on the ‘to pin’ in the graphical window, then click on the ‘from pin’ and then right click and choose Add From-To from the menu that pops up. This adds a new From-To to the From-To’s list and displays the From-To in the graphical window.

When you move the cursor over a pad in the graphical window, the designator and pin number of the pad is displayed immediately below the graphical window. Double-click on a pad to edit its properties.

To remove a From-To, click on the From-To name or the From-To in the graphical window, then right click and choose Remove From-To from the menu that pops up.

The Auto Generate section allows you to assign From-To’s for a complete net to a specific topology.
7 Component Placement Tools

General Notes

Once Components are placed in the file after running the Synchronizer (Design » Update PCB in the Schematic editor), you can make use of all the following placement tools to achieve a final placement:

- Move Component
- Auto Placement
- Interactive Placement

The quality of the component placement may determine whether or not your design can be routed.

7.1 Placing Components With Predetermined Locations

Almost every PCB will have some components that must be placed in a specific location. These typically include connectors, switches and indicating lights.

If you can visually locate such components, click and hold on the to move them.

Otherwise, select the menu command Edit » Move » Component and then give a mouse click where there are no objects. This displays a dialog box in which you could enter the Designator of the component to be placed. If you press ENTER, a list of all Designators is displayed. From this list, you can select the component to be placed and that component will appear on the cursor ready to be placed. Press the TAB key to display the Component dialog box and in the Properties tab, check the Locked check box. This will lock the component so that it will not be moved by other placement commands.

Repeat this for all components with pre-determined locations.

7.2 Moving Components

Click and hold on a component to move it. While you are moving the component, the Connection Lines directly connected to it will drag with it while all other Connect Lines are not displayed. As you move the component Connect Lines are dynamically optimised such that every Connect Line is following the shortest path to any other object with the same net name.

You will also notice that as you click and hold on a component, a thicker line with a dot at either end displays. This “placement quality vector” indicates the distance from the optimum placement position for that component, based on connect line length. This will help you decide on the best location for each component as you are refining the placement.

Also, while you are moving a component, pressing the N key will toggle the display of connections.

Pressing the L Key while moving a component toggles the component between the top and the bottom of the PCB.

7.3 Component Unions

The Union feature allows you to group components together so that they can be moved as a group as if they were a single component. Multiple Unions can be defined.
To create a Union of components, select the components then choose the Create Union command on the Component Placement toolbar.
To remove a component from a Union or to remove the Union, choose the Break Union command on the Component Placement toolbar. This displays a dialog box that lists all components in the Union. From here, select the component(s) to be removed from the Union. Selecting all components removes the union.

### 7.4 Rooms
A room is a rectangular object that defines an area where components can either be kept within or kept out of. These rectangular objects are called Room Definitions. They are placed using the **Place » Room** menu command or from the Placement toolbar. Once a room definition object is placed, you define the components associated with it and whether they are to be kept in or kept out in the Placement tab of Design Rules.
If a component is moved such that it is in violation of the Room Definition rule, it is displaced with a DRC marker.
There is also an **Arrange Within Room** command that places components within the room they have been assigned to.

### 7.5 Component Placement Grids
When Placing or Moving components, they “snap” to the Component Placement grid. This grid has an X and a Y value and they are set in the Option tab of Document Options.

### 7.6 Density Map
The Density Map command is provided to allow you to evaluate the quality of your component placement. It generates a graphical display of the connection density of the PCB layout. It is analogous to a thermal contour map. The “hot” areas, which display in red, indicate areas that are too dense to successfully route. Look at any red areas and try to create more routing space.
To display the Density Map, select the **Tools » Density Map** command. When you are finished with the density map, select the **View » Refresh** command or the End shortcut key to display the PCB editor workspace.
7.7 Interactive Placement Commands

There are a number of “semi-automated” tools that allow you to edit the placement of your PCB design. They are accessed via the Tools » Interactive Placement menu and the Component Placement toolbar. These are described in the following sub-sections.

7.7.1 Alignment Commands

Use these to ‘fine tune’ your component placement. The Alignment commands operate on any selected components.

7.7.2 Arrange Commands

These automatically move components as follows:

<table>
<thead>
<tr>
<th>Arrange Within Room</th>
<th>Components assigned to the nominated room are placed within that room</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrange Within Rectangle</td>
<td>Selected components are placed with an area</td>
</tr>
<tr>
<td>Arrange Outside Board</td>
<td>All unlocked components are moved outside the board area</td>
</tr>
</tbody>
</table>

7.7.3 Move To Grid

All Unlocked components are moved to the closest Component Placement Grid point.

7.8 Auto Placement

The Automatic Placement attempts to optimally place all components in the PCB file, which are not locked. It uses the largest enclosed shape on the Keep Out layer to determine the space available for placement and will not place components in any enclosed shapes on the Keep Out layer within the board outline. The PCB editor provides two options for Auto Placement, both using a different method of calculating and optimising component positions suitting to different board densities. These options are:

- **Cluster Placer**: groups components into clusters based on their connectivity, and then places these clusters geometrically. The algorithms in this auto placer are more suited to designs with a lower component count (less than 100).

- **Statistical Placer**: uses a statistical algorithm to place the components in an attempt to minimise the connection lengths. As it uses a statistical algorithm it is best suited to designs with more than 100 components.
7.8.1 Cluster Placer

To run the Cluster Placer, select the menu command **Tools » Auto Place** and this displays the Auto Place dialog box shown below. Click on the Cluster Placer radio button. The Cluster placer adheres to the Placement rules defined in the Design Rules.

![Auto Place dialog box](image)

*Figure 20 Autoplace dialog box*

7.8.2 Statistical Placer

To run the Statistical Placer, select the menu command **Tools » Auto Placement** and this displays the Auto Place dialog box shown above. Click on the Statistical Placer radio button. The parameters you can set Statistical Placer are described below:

- **Group Components** that are “tightly” connected are grouped together and effectively treated as one component for Auto placement.
- **Rotate Components** Allows components to be rotated
- **Grid** This is the grid each component reference point will be placed on.

**Power Nets and Ground Nets Fields**

This section performs the following functions:

As a power net is typically connected to most components, little is achieved by attempting to optimise it. Any nets entered in this these fields will not be considered by the Auto Place process. Using this option will speed up the Auto Placement.

Any components connected to both these nets will be considered to be de-coupling capacitors and will be grouped with large components (greater than 14 pins).

Note: Before running the Statistical Auto Placer, you should set the origin to the Absolute Origin (**Edit » Origin » Reset**).
Once the parameters have been set, click on OK. This launches the Auto Placer, which runs in a separate editor window.

You can stop the Auto Placer at any time by closing the Auto Placer window. You are then prompted as to whether you want to update the PCB file with the current placement.

7.8.3 Shove

This command allows you to place a component on a PCB so that it slightly overlaps other components on the board, and then automatically shoves the overlapping components to allow the new component to fit.

The Shove commands are located in the Tools » Auto Placement menu.

To do this, select Shove from the Tools » Auto Placement menu. The cursor will change to a crosshair. Position the cursor over the component that is to be positioned on top of other components and left-click or press ENTER. All the components that surround the selected component and are in contact with it will be moved aside to make room for the component, clearances permitting.

If a shoved component hits the edge of the Keep Out perimeter, there will be a "bounce back" effect and that component will back away from the edge and shove the other components until there is no overlap. To avoid shoving a particular component, enable its Locked attribute.

To control the "ripple" effect that shoving can produce, you can limit the number of subsequent component shoves (those produced by the initial shoved components) set the Shove Depth. A setting of "1" means that only the components which directly violate the "target" component will move until they are clear of the target. Setting the depth to "2" means that the process is repeated, allowing the newly shoved components to shove any components that they now overlap. Setting the depth to higher numbers allows more iterations of the process. To avoid unpredictable results on complex and dense designs, it is advisable to set the shove depth to a low number (the default is 1).
7.9 Re-Annotation

The PCB Editor provides the Re-Annotation command to re-number component designators, such that they are numbered in some kind of order. To do this, choose the Tools » Re-Annotate menu command. This displays the Positional Re-Annotate dialog box shown below. You select the Method by which you want the re-annotation to be performed and then click OK.

Alternatively, you edit individual component designators by double-clicking on the component.

![Positional Re-Annotate dialog box](image)

You can update the Schematic with the designator changes using the Synchronizer. To do this, select Design » Update Schematic.
8 Routing

8.1 Interactive Routing

The Interactive Route command has some very powerful features that are available when placing tracks. These are described below.

8.1.1 Managing Connectivity

Once components are placed into a PCB file, Connection Lines display to indicate unconnected nets. Whenever there is an operation on a copper layer which effects connectivity, the PCB editor analyses the PCB to determine if any connections have changed. If any connections have been made by tracks, connection lines are no longer displayed. Also, if a shorter path for any connection is created by a new connection, a shorter connection line is displayed.

8.1.2 Track Width

When using the Interactive Routing command, the setting for Preferred Width in the Width Constraint design rules determines the track width.

8.1.3 Interactive Routing Mode

Interactive Routing Mode is set in the Options tab in the Preferences dialog. If it is set to ‘Avoid Obstacle’, you cannot place a track in violation of the design rules. If it is set to ‘Push Obstacle’, tracks in the path of the track being placed are automatically pushed aside to allow it to be routed.

8.1.4 Look Ahead Routing

The PCB editor incorporates the “look-ahead” feature that operates as you place tracks. The track segment that is connected to the cursor is a look-ahead segment (displays in outline/draft mode). The segment between this look-ahead segment and the last-placed segment is the current track that you are placing (displays in final mode).

Use the look-ahead segment to work out where you intend to place the next segment and to determine where you wish to terminate the current segment. When you click to place the current segment, its end point will be positioned exactly where you need to commence the next segment. This feature allows you to quickly and accurately place tracks around existing objects and plan where the next track segment can be placed.

As you use the look-ahead segment to guide your routing, you will notice that the track end does not always remain attached to the cursor. It “avoids” electrical objects that belong to another net. This feature prevents you from violating any clearance constraints.

8.1.5 Interactive Routing Properties

When using Interactive Routing, track width is determined by the Width Constraint design rules. Pressing the tab key while routing displays the Interactive Routing dialog box, where you can set width and via properties.
8.1.6 Loop Removal

The Loop Removal Function is activated automatically when the **Interactive Routing** command is in use. This feature helps you to edit a track once you have placed it. For example, you realise that a track you have placed occupies a routing channel that you need for another track.

**Editing a Track Using the Loop Removal Feature**

Select the **Place » Interactive Routing** command.

Position the cursor on the section of track you wish to edit.

Click to initiate the starting point of the new track section.

Place the new track.

Click on the existing track section to finish placing the new track section.

Notice that the old track disappeared when you clicked to place the finish point of the new track!

**Note:** The loop removal function only works if both the starting point and the finishing point of the new track lay within the original track section (i.e. no pads can be within the section being edited).

If you do not want this function to operate while you are placing tracks:

- Press the OP on your keyboard to display the **Preferences Dialog** box
- Unmark the Loop Removal box in the **Options** tab

**Electrical Grid**

When in the interactive routing command, an octagonal graphic displays on the cursor whenever the Electrical Grid snaps the cursor to an object assigned to a net.
8.2 Automatic Routing

General Notes

- The automatic router is a Shape Based Router that uses Neural Net techniques to assign routing parameters to each connection.
- You can learn more about Advanced Route by reading the ‘Autorouting a Printed Circuit Board’ section in Help (you will find it in Help Contents)
- Where appropriate, design rules are adhered to by the autorouter.

8.2.1 Automatic Routing Tips

- The board must include a closed boundary on the keep out layer.
- You can protect pre-routed connections, fan-outs and entire nets by enabling the Protect Pre-routes option in the Autorouter Setup dialog. This option also protects fan outs and partially routed connections.
- Objects with a net name that are not locked may be moved/ripped up during routing.
- Objects placed on the keep out layer create blocks for the router on all layers.
- Signal layer objects with no net name create blocks for the router on that signal layer.
- The router does not consider objects on the mechanical layer.

8.2.2 Setting Up the Automatic Router

- The Autorouter requires minimal set up. Select Auto Route » Setup to display the Autorouter Setup dialog box shown below.

![Autorouter Setup dialog box](image)

*Figure 21 Autorouter Setup dialog box*
You simply click on the check boxes next to the Route Passes you would like performed. For an unrouted PCB, you would most likely check all of them.

### 8.2.3 Autorouter Options

Once the Autorouter has been set up, you can choose any of the following options in the **Auto Route** menu:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Routes the complete PCB</td>
</tr>
<tr>
<td>Net</td>
<td>Routes a complete net. You are prompted to select the net</td>
</tr>
<tr>
<td>Connection</td>
<td>Routes a connection within a net as defined by a connection line. You are prompted to select the connection</td>
</tr>
<tr>
<td>Component</td>
<td>Routes all connections to a component. You are prompted to select the component</td>
</tr>
<tr>
<td>Area</td>
<td>Routes all connections within an area. You are prompted to define the area.</td>
</tr>
</tbody>
</table>

At any time while the PCB is being routed you can temporarily stop it using the **Auto Route » Pause** menu command and re-start it using **Auto Route » Start**.

The routing can be terminated using the **Auto Route » Stop** command. Any connections made by the autorouter are kept.

Any or all of the connections made by the autorouter can be removed using the un-route commands in the **Tools** menu.
9 Polygons

General Notes

- A polygon is an area of copper on a signal layer, usually connected to a net, that is “poured” over existing objects, such as tracks and pads.
- They can be solid or hatched.
- They maintain a clearance, set in the design rules, away from other copper objects.
- They are made up of tracks and arcs but is recognised as a single object.
- They can be any enclosed shape comprising lines and arcs.
- They can be placed on other layers but do not pour around other objects when not placed on signal layers.

9.1 Placing a Polygon

Place a polygon using the **Place > Polygon Plane** menu command or this toolbar button. This displays the Place Polygon Plane dialog box in which you set up the parameters for the polygon.

![Polygon Plane dialog box](image)

*Figure 22 Polygon Plane dialog box*
The parameters for Place Polygon are listed below:

**Net Options**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect to Net</td>
<td>Select the net to connect the polygon to</td>
</tr>
<tr>
<td>Pour Over Same Net</td>
<td>Existing tracks within the polygon which are part of the net being connected to will be covered by the polygon.</td>
</tr>
<tr>
<td>Remove Dead Copper</td>
<td>Removes any part of the polygon that cannot connect to the plane net</td>
</tr>
</tbody>
</table>

**Plane Settings**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid Size</td>
<td>Spacing between tracks that make up the polygon</td>
</tr>
<tr>
<td>Track Width</td>
<td>Width of tracks that make up the polygon</td>
</tr>
<tr>
<td></td>
<td>If Track Width is equal to the Grid Size, the polygon ends up as solid copper.</td>
</tr>
<tr>
<td></td>
<td>If Grid Size is greater than Track Width, the polygon ends up as hatched.</td>
</tr>
<tr>
<td>Layer</td>
<td>Select the signal layer that the polygon is to be place on.</td>
</tr>
<tr>
<td>Lock Primitives</td>
<td>If unchecked, individual objects (i.e. tracks or arcs) that make up the plane can be deleted.</td>
</tr>
</tbody>
</table>

**Hatch Style**

<table>
<thead>
<tr>
<th>Hatch Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>90-Degree Hatch</td>
<td>Polygon is hatched with horizontal and vertical tracks</td>
</tr>
<tr>
<td>45-Degree Hatch</td>
<td>Polygon is hatched with tracks at 45 degrees and 135 degrees</td>
</tr>
<tr>
<td>Vertical Hatch</td>
<td>Polygon consists of only vertical tracks</td>
</tr>
<tr>
<td>Horizontal Hatch</td>
<td>Polygon consists of only horizontal tracks</td>
</tr>
<tr>
<td>No Hatching</td>
<td>Only outlines are poured</td>
</tr>
</tbody>
</table>

**Surround Pads With**

<table>
<thead>
<tr>
<th>Surround Pads With</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Octagons</td>
<td>Places a track to form an octagon around pads</td>
</tr>
<tr>
<td>Arc</td>
<td>Places an arc around pads</td>
</tr>
</tbody>
</table>

Minimum Primitive Size - Tracks or arcs below this setting are not placed

### 9.2 Editing a Polygon

Once a polygon has been placed, either double-clicking on the polygon or selecting the **Edit » Change** menu command and clicking on the polygon can change any of the parameters, which you set in the Place Polygon dialog box. This displays the Place Polygon dialog box where you can change any of the parameters and then click OK. You are then prompted to re-pour the polygon.
9.3 Moving a Polygon

Move a polygon as you would any other object. Click and hold and move it to the next location. When you release the mouse button, you are prompted to re-pour the polygon.

9.4 Editing Polygon Vertices

To move or insert vertices on a polygon, select the Edit » Move » Polygon Vertices command and click on the polygon to be moved. This polygon will display handles at each vertex and a small cross the centre point of each line segment of its border. To move a vertex, click and drag on the handle for that vertex. To insert a vertex, click and hold on the cross in the line segment and drag it to where the vertex is required.

9.5 Deleting a Polygon

To delete a polygon, select the Edit » Delete command and then click on the polygon to be deleted.

9.6 Exercises – Working with Polygons

1. Open the file Z80 Processor Board.pcb

2. Place a Polygon Plane covering 3 or four IC’s using the parameters in the Polygon Plane dialog box shown in Figure 22.

3. Double-click on the polygon to edit it and change the grid sizes to 25mil and Hatching style to 45-Degree Hatch and then re-pour the polygon.

4. Click and hold on the polygon and move it by 2 snap grid points.

5. Use the Edit » Move » Polygon Vertices menu command to change the shape of the polygon.

6. Use Edit » Delete to delete the polygon.
10 Design Rule Checking

- The Design Rules Checking (DRC) functions are provided to check that your design conforms to the design rules.
- There are both On-line and Batch DRC functions.
- A design should only be submitted for manufacturing when all DRC violations have been resolved.
- DRC violations can be located using the Violations browser in the Browse section of the PCB Editor Panel

10.1 On-Line DRC

If the On-Line DRC option is turned on, any DRC violations cause are marked as you create them. Checking the On-Line DRC check box in the Options Tab of the Preferences dialog box turns on the On-Line DRC.

You can configure which Design Rules are checked by the On-Line DRC from the On-Line Tab of the Design Rule Checking dialog box shown in Figure 23. This dialog box is displayed by selecting the Tools » Design Rule Check menu command.

![Design Rule Check dialog box](image)

*Figure 23 On-Line Tab of the Design Rule Checking dialog box*
The interactive routing command has an addition On-Line DRC function as detailed in the table below:

<table>
<thead>
<tr>
<th>Interactive Routing Mode parameter in the Options tab of the Preferences dialog box</th>
<th>On-Line DRC action when rules are violated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avoid Obstacle</td>
<td>Prevents track being placed</td>
</tr>
<tr>
<td>Ignore Obstacle</td>
<td>Places DRC marker</td>
</tr>
<tr>
<td>Push Obstacle</td>
<td>Moves obstacle</td>
</tr>
</tbody>
</table>

10.2 Design Rules Check Report

This is often referred to as the Batch DRC. This performs design rules checks based on the options selected. Selecting the **Tools » Design Rule Check** menu command runs the DRC. This displays the Design Rule Checking dialog box shown in Figure 24. This will run a DRC check on the PCB and mark any violations found.

![Design Rule Check dialog box](image)

*Figure 24 Report Tab of the Design Rules Checking Dialog box*

The Rules sections of this dialog box enable you to select which design rules the DRC will check violations for.

Note the ‘All On’ and ‘All Off’ buttons in these sections. They either check or un-check all options in the section.

10.3 Locating Design Rule Violations

The following are provided to locate DRC violations:

- **Violations browser** in the Browse section of the PCB Editor Panel
**Jump to Error Marker** Select this command using **Edit > Jump > Error Marker**. When invoked, the PCB editor locates the next DRC violation and zooms in on it and displays in centre screen. Each time this command is selected, the next Error marker is displayed. You can also use the Jump command to jump to components, nets, pads, strings or coordinates.

**Cross Probing** To use Cross Probing, switch to the DRC report file in the Text editor. Select the text relating to the object that you would like to locate in the PCB editor. This can be any of the following:

- Designator
- Designator-Pin
- Coordinate
- String

Then select the Cross Probe toolbar button in the text editor toolbar. Switch to the PCB editor and the selected object will be displayed centre screen.

### 10.4 Exercise

1. Open the PCB in the Z80 Microprocessor database.
2. Define a Clearance Constraint design rule to ensure that the RAWBAUD net maintains a clearance of 200 mils from the net 19200.
3. Route these nets using the interactive routing command with Push Obstacle on.
4. Test that the rule prevents you from creating a violation
11 Printing

Printing from your PCB document is performed using Protel’s Print/Preview utility. This allows you to control the complete printing process from definition of layers to print, previewing and printing.

11.1 Running Print/Preview

Print/Preview is invoked by clicking on the Printer icon on the Main toolbar or from the Print/Preview command in the File menu. This launches the Print/Preview server that creates a new PowerPrint Configuration document (.PPC) as shown below.

In the display window of this document, a print preview of your PCB is displayed. In the Browse PCBPrint tab of Design Manager a list of Printouts in this document are displayed. Clicking on the + next to the Printout icon expands out the list of layers that comprise that printout.

To print to a printer, there are the following options:

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print All</td>
<td>Prints all Printouts</td>
</tr>
<tr>
<td>Print Job</td>
<td>Prints all Printouts as a single print job</td>
</tr>
<tr>
<td>Print Page</td>
<td>Prints the currently displayed preview</td>
</tr>
<tr>
<td>Print Current</td>
<td>Prints the current Printout</td>
</tr>
</tbody>
</table>
Also, clicking on the Printer icon on the Main toolbar performs Print All.

The **Tools** menu contains the following commands for creating pre-defined Printouts:

- Create Final
- Create Composite
- Create Power Plane-Set
- Create Mask Set
- Create Drill Drawings
- Create Assembly Drawings
- Create Composite Drill Guide
- Customising a Printout

To customise a Printout, right click on the Printout icon and choose Properties. This displays the Printout Properties dialog box shown.

![Printout Properties Dialog Box](image)

To add a new layer to a Printout, right click on the Printout icon and choose Insert Print Layer. You then need to set the properties of the new layer just added by right clicking on that layer’s icon and choose Properties. This displays the Layer Properties dialog box shown over.
In this dialog box you can set the PCB layer to be printed and also the display mode properties of each object type on that layer. This determines how they will print (Full, Draft or Hidden mode).

*Figure 25 Layer Properties dialog*
11.2 Setting Scale and Orientation and Printer Options

Choose the Setup Printer command in the File menu to display the PCB Print Options dialog box shown.

![PCB Print Options dialog box](image)

*Figure 26 Setting the printer options*

11.3 Copying Print Preview to the Window Clipboard

You can copy the current Printout preview to the Windows clipboard by clicking on the Copy icon on the Main toolbar or the Edit » Copy menu command. You can also save the image as a Windows Metafile by choosing the File » Export menu command.

11.4 PPC Documents

The Print/Preview documents can be renamed and copied either the current Design folder or to other folders. You can use a Print/Preview document with another design by copying it to the appropriate folder and changing the PCB to be printed by choosing the Tools » Set Target Board menu command.
12 CAM Manager

The CAM Manager gives you total control over the setup and creation of the manufacturing output files, including Gerber, NC drill and pick and place. The setups are saved with the design in a CAM Output Configuration document and can be modified at any time. CAM documents can also be copied from one design to another, making it easy to transfer your preferred output file configurations.

To create a new CAM document for the current PCB select the File » CAM Manager menu command. A blank CAM document is created, and the Output Wizard will automatically start. Using the Wizard you can create an Output Setup for each type of output.

CAM Manager supports the following outputs:

- Bill of Materials
- DRC
- Gerber
- NC Drill
- Pick and Place
- Test Point Report

You can add a new Output Setup to your CAM Output Configuration document from the Editor menu or by right clicking in the document editor window. Once an Output Setup is created, it can be edited by double-clicking on its entry in the list of Output Set-ups.
CAM Outputs are generated by:

- Generate CAM Outputs button on the Main toolbar
- The **Tools » Generate CAM Files** menu command
- F9 function key

The data is output into appropriate documents in a CAM folder within the same folder as your PCB file. The name is determined by settings in the CAM Options dialog box that is displayed by choosing the **Tools » Preferences** menu command.
12.1 Bill Of Materials

This option produces Bill of Materials reports (Parts Lists). Double-clicking on a Bom Output Setup displays the Bill of Materials Setup dialog box shown. Output format options are Text, CSV (Comma Separated Variables) and Spreadsheet.

12.2 DRC

This option produces a Design Rules Check report. Double-clicking on a DRC Output Setup displays the DRC Setup dialog box shown.
12.3 Gerber

This option produces a Photoplotter output in Gerber format. Double-clicking on a Gerber Output Setup displays the Gerber Setup dialog box shown.

Consult your PCB manufacturer for their preferred settings.

12.4 NC Drill

This option produces a NC drill output in an industry standard format. Double-clicking on a NC Drill Output Setup displays the NC Drill Setup dialog box shown.

Consult your PCB manufacturer for their preferred settings.
12.5 Pick and Place

This option produces component data that is used to program a Pick and Place machine. Double-clicking on a Pick Place Output Setup displays the Pick and Place Setup dialog box shown.

12.6 Test Point Report

This option produces information on the location and size of Testpoints for use in fabricating test fixtures and programming testers.

Double-clicking on a Testpoints Output Setup displays the Test Point Setup dialog box shown.
13 3D Viewer

The 3D Viewer allows you to generate a 3D model of your PCB that you can view from any angle. This enables you to visualise what the PCB will look like.

The benefits of the tool are to help locate design errors very early in the design process. Some examples are:

- Component placement problems
- Mechanical interference problems
- Assembly problems

To run the 3D Viewer, click on this button on the main toolbar.

The 3D Viewer has a separate tab from the PCB Editor. A 3d view of your PCB displays is the editor view and you can control your view of the PCB from the Browse PCB3D tab of the Design Manager panel.

To model components in 3D, 3D Viewer uses a run-time component modelling algorithm that uses the component designator prefix, footprint and outline shape to automatically select model and texture information and construct a suitable component model. Components that cannot be recognized are automatically extruded.
Options for the 3D Viewer are set using the **View » Preferences** menu command in the 3D Viewer. This displays the Preferences dialog box shown.

To change the view of the PCB you position the cursor in the MiniViewer in the Browse PCB3D tab of the Design Manager panel. You then click and hold and move the cursor to rotate the viewer of the PCB.

A Highlight net function is provided that allows you to see tracks belonging to selected nets. Choosing Animated Highlighting in Preferences causes the selected tracks to “pulsate”.
14 PCB Library Editor

The PCB Library Editor is provided to create and modify PCB components and manage PCB component libraries. In addition to enabling you to build components as required, it also provides a Component Wizard to guide you through the creation of most common PCB component types.

14.1 The PCB Library Workspace

The PCB Library editor workspace is shown below.

![PCB Library Editor Workspace](image)

*Figure 27 PCB library Editor Workspace*

The view commands, primitive objects, layers, selection and focus, grids and general editing functions are all identical to the PCB editor.

Also, settings in the Preferences dialog box and Document Options dialog box also apply in the PCB Library editor.
14.2 PCB Library Editor Panel

The PCB Library Editor panel provides a number of facilities for working with PCB components. These are described below:

Component Section

The top section of the panel comprises a scroll box that lists all the components in the active library. The Mask field allows you to selectively list components. The buttons at the bottom of component list do the following:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Move the cursor up one component in the list</td>
</tr>
<tr>
<td>&lt;&lt;</td>
<td>Move the cursor to the top of the list</td>
</tr>
<tr>
<td>&gt;&gt;</td>
<td>Move the cursor to the bottom of the list</td>
</tr>
<tr>
<td>&gt;</td>
<td>Move the cursor down one component in the list</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the selected component</td>
</tr>
<tr>
<td>Place</td>
<td>Places the selected component into the active file in the PCB editor</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the selected component from the library</td>
</tr>
<tr>
<td>Add</td>
<td>Creates a new component and launches the Component Wizard.</td>
</tr>
</tbody>
</table>

The scroll box in the lower part of the components section lists the pin numbers of the pads in the selected component. Click on a pin number to select it and then click on the Edit button (or double-click on the pin number text) to display the Change Pad dialog box.

Click on the Jump button to zoom in on the selected pad in the display window.

The Current Layer Section displays the current layer and allows you to change the current layer by clicking on the down arrow.
14.3 Creating a Component Using the Component Wizard

The PCB Library editor includes the Component Wizard. This Wizard allows you to select the component category and fill in appropriate information and then builds the component for you.

To launch the Component Wizard press the Add button on the Library Editor panel or select the **New Component** menu item in the **Tools** menu.

14.4 Manually Creating a Component

Components are created in the PCB Library Editor using the same set of primitive objects available in the PCB Editor. In addition to PCB components, corner markers, phototool targets, mechanical definitions etc can be saved as components.

The typical sequence for manually creating a component footprint is:

Open the desired library in the Library Editor.

Select the **Tools » New Component** menu command. The Component Wizard will automatically start, press Cancel to manually create a component. You will be presented with an empty component footprint workspace, called PCBComponent_1. Select **Tools » Rename Component** to change this to the required name. Component names can be up to 255 characters.

Use Tracks or other primitive objects to place the component outline on the Silkscreen layer.

Place the pads according to the component requirements. When a pad is floating on the cursor select **Edit » Jump » Reference** to position the cursor at the workspace 0, 0 coordinate. Prior to placing the first pad, press the Tab key to define all the pad properties. Make sure you set the Designator property correctly. Typically, the first pad you place is pin 1 so the set designator to 1 for the first pad. The designator automatically increments.

14.5 Copying a Component

There is often the requirement to copy components, either from one library to another or within the same library. To achieve this use **Edit » Copy Component**. This copies any components that are selected in the Components list in the editor panel to the Clipboard. To select a component, click on the name text of that component. To select additional components, use Ctrl+Click.

You then use **Edit » Paste Component** to paste components on the Clipboard into the active PCB Library document.

14.6 Special Strings in the Library Editor

There are two special strings that are active in the library editor which are provided to allow you to control the positioning of the Designator and the Comment.

These special strings are:

```
.Designator
.Comment
```
Place these in the PCB Library editor workspace at the location relative to the component where you would like the designator or comment to be placed.

When you use these, you can hide the default designator and comment that are added when the component is placed in the PCB file.

14.7 Component Rule Check

The Component Rule Check command in the Reports menu allows you to check either the current component or the whole Library for any of the following:

- Duplicate pads
- Duplicate primitives (i.e. identical objects at the same coordinate)
- Duplicate component names
- Missing pad designator
- Bottom layer components
- Reference outside component objects
- Shorted copper
- Unconnected copper

The results of the component rule check are displayed in a text document.

14.8 Exercise – Libraries and Components

1. Create a new library file using File » New.

2. Create a new component of your choice using the Component Wizard (use Tools » New Component).
# 15 Short Cut Key Summary

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>L</td>
<td>Layers Tab of Document Options</td>
</tr>
<tr>
<td>Q</td>
<td>Toggle Units</td>
</tr>
<tr>
<td>PgUp, PgDn</td>
<td>View » Zoom In, View » Zoom Out</td>
</tr>
<tr>
<td>CTRL+PgUp/PgDn</td>
<td>Zoom maximum / minimum</td>
</tr>
<tr>
<td>SHIFT+ PgUp/PgDn</td>
<td>Zoom at 0.1 step rate</td>
</tr>
<tr>
<td>HOME</td>
<td>View » Pan</td>
</tr>
<tr>
<td>END</td>
<td>View » Refresh</td>
</tr>
<tr>
<td>CTRL+HOME</td>
<td>Jump Absolute Origin</td>
</tr>
<tr>
<td>CTRL+END</td>
<td>Jump Current origin</td>
</tr>
<tr>
<td>CTRL+INS</td>
<td>Edit » Copy</td>
</tr>
<tr>
<td>CTRL+DEL</td>
<td>Edit » Clear</td>
</tr>
<tr>
<td>SHIFT+INS</td>
<td>Edit » Paste</td>
</tr>
<tr>
<td>SHIFT+DEL</td>
<td>Edit » Cut</td>
</tr>
<tr>
<td>ALT+BACKSPACE</td>
<td>Undo</td>
</tr>
<tr>
<td>CTRL+BACKSPACE</td>
<td>Redo</td>
</tr>
<tr>
<td>SHIFT+F4</td>
<td>Cascade Windows</td>
</tr>
<tr>
<td>SHIFT+F5</td>
<td>Tile Windows</td>
</tr>
<tr>
<td>*</td>
<td>Toggle active signal layers</td>
</tr>
<tr>
<td>+ or -</td>
<td>Next / previous active layer</td>
</tr>
<tr>
<td>F1</td>
<td>Help Index</td>
</tr>
</tbody>
</table>

## Popup Menus

<table>
<thead>
<tr>
<th>Key</th>
<th>Menu Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Tools » Align submenu</td>
</tr>
<tr>
<td>B</td>
<td>View » Toolbars submenu</td>
</tr>
<tr>
<td>G</td>
<td>Snap Grid popup menu</td>
</tr>
<tr>
<td>J</td>
<td>Edit » Jump submenu</td>
</tr>
<tr>
<td>M</td>
<td>Edit » Move submenu</td>
</tr>
<tr>
<td>O</td>
<td>Options popup menu</td>
</tr>
<tr>
<td>S</td>
<td>Edit » Select submenu</td>
</tr>
<tr>
<td>U</td>
<td>Tools » Unroute submenu</td>
</tr>
<tr>
<td>X</td>
<td>Edit » DeSelect menu</td>
</tr>
<tr>
<td>Z</td>
<td>Zoom popup menu</td>
</tr>
</tbody>
</table>
### Interactive Routing

<table>
<thead>
<tr>
<th>Key combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BACKSPACE</td>
<td>Removes the previously placed track segment while routing a connection.</td>
</tr>
<tr>
<td>*</td>
<td>Toggles through the routing layers while routing.</td>
</tr>
<tr>
<td>/</td>
<td>Places a via connecting to a power plane.</td>
</tr>
<tr>
<td>TAB</td>
<td>Pop up the Track properties dialog box to edit track attributes while routing.</td>
</tr>
<tr>
<td>SHIFT+R</td>
<td>Cycles through the interactive routing modes.</td>
</tr>
<tr>
<td>SHIFT+S</td>
<td>Toggles single-layer display mode on and off.</td>
</tr>
<tr>
<td>SPACEBAR</td>
<td>Changes between track placement start and end angle modes.</td>
</tr>
<tr>
<td>SHIFT+SPACEBAR</td>
<td>Cycles through the track placement modes.</td>
</tr>
<tr>
<td>CTRL+SPACEBAR</td>
<td>Cycles through the connection lines connecting to a pad.</td>
</tr>
<tr>
<td>CTRL</td>
<td>Temporarily suspends the electrical grid.</td>
</tr>
<tr>
<td>ALT</td>
<td>Temporarily switches from Avoid Obstacle to Ignore Obstacle mode.</td>
</tr>
<tr>
<td>End</td>
<td>Refreshes the display while routing.</td>
</tr>
</tbody>
</table>

### Useful Information

<table>
<thead>
<tr>
<th>Category</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Protel Website</td>
<td><a href="http://www.protel.com">www.protel.com</a></td>
</tr>
<tr>
<td>Protel User Group</td>
<td><a href="mailto:PROTELEDAUSERS@techservinc.com">PROTELEDAUSERS@techservinc.com</a></td>
</tr>
</tbody>
</table>